HSRP Config …

Posted on October 11, 2006. Filed under: Cisco |

All,
I have a pair of Cisco 3750 stacks (IOS 12.2(25)SEB4), connected to each
other via an Etherchannel trunk, with two separate uplinks to my ISP.
Both are, independently, able to reach the outside world. I’ve also set
up an HSRP interface on the stack(s), such that 10.10.10.1 is my standby
IP, .2 is the first stack, and .3 is the second stack. Our servers are
able to use .1 as their default gateway, and everything works as I would
expect it to up to this point.
What I had been planning to do is configure a static route on each
switch stack, pointing to the stack on the other side of the
Etherchannel, with a higher administrative distance than the default
route. This way, on a given switch, if/when the default route to the
outside is withdrawn from the routing table, traffic will pass across
the Etherchannel and to the secondary stack, where it will then be
routed to the outside.
However, the route isn’t being installed in the routing table.
HSRP config is barebones:
stack 1’s vlan interface:

interface Vlan999
description sanitized
ip address 10.10.10.2 255.255.255.0
standby 1 ip 10.10.10.1
standby 1 priority 110
and on stack 2:

interface Vlan999
description sanitized
ip address 10.10.10.3 255.255.255.0
standby 1 ip 10.10.10.1

HSRP failover for the interface works without a hitch, and I can ping /
traceroute from the vlan 999 interface on one switch to the other
without issue. On both switches, the interface is up/up.
The static route is configured as such:
ip route 0.0.0.0 0.0.0.0 my.next.hop.address
And I’m trying to add:
ip route 0.0.0.0 0.0.0.0 next.hop.on.other.side.of.etherchannel 100
Even when I break the HSRP config and make these two standalone
interfaces, the route isn’t installed.
The Etherchannel is a dot1q trunk, and the VLAN is allowed on the trunk
on both ends of the stack. And, as I said, I can ping / traceroute to
the 10.10.10.3 interface from 10.10.10.2 (which lives on the primary
switch stack, on the other side of the Etherchannel) without issue, and
vice versa.
Any insight would be appreciated here, as I’m stumped.
Thanks,
–afsheenb
_______________________________________________
cisco-nsp mailing list cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/

Make a Comment

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Liked it here?
Why not try sites on the blogroll...

%d bloggers like this: