Cisco STP for Redundancy & Resiliency

Posted on April 15, 2008. Filed under: Cisco, Failover, Spanning-Tree, Trunk, Vlan |

Using STP for Redundancy, gives you :

– Resilience Time about 2 seconds for Link Recovery once primary trunk goes down and took over by the second one
– Resilience Time about 25 seconds for Link Recovery once primary trunk goes up and took over the link from the secondary trunk

Connection Scheme :

a. SWITCH 1 [SW1]
– Port F0/1 Trunked to Port F0/2 [SW2]
– Port F0/2 Trunked to Port F0/1 [SW3]
– Port F0/24 Vlan Access 20 to PC-A
b. SWITCH 2 [SW2]
– Port F0/1 Trunked to Port F0/2 [SW3]
– Port F0/2 Trunked to Port F0/1 [SW1]
c. SWITCH 3 [SW3]
– Port F0/1 Trunked to Port F0/2 [SW1]
– Port F0/2 Trunked to Port F0/1 [SW2]
– Port F0/24 Vlan Access 20 to PC-B

IP Address :
PC-A : 10.10.10.2 /24
PC-B : 10.10.10.3 /24

+++++++++++++++++++++++++++++++++++++++
SWITCH 1 :

interface FastEthernet0/1
duplex full
speed 100
switchport mode trunk
spanning-tree vlan 1 port-priority 1
!
interface FastEthernet0/2
duplex full
speed 100
switchport mode trunk
spanning-tree vlan 1 port-priority 2

interface FastEthernet0/24
duplex full
speed 100
switchport access vlan 20
spanning-tree portfast

++++++++++++++++++++++++++++++++++++++++

SWITCH 2 :

interface FastEthernet0/1
duplex full
speed 100
switchport mode trunk
spanning-tree vlan 1 port-priority 1
!
interface FastEthernet0/2
duplex full
speed 100
switchport mode trunk
spanning-tree vlan 1 port-priority 2
++++++++++++++++++++++++++++++++++++++++

SWITCH-3 :

interface FastEthernet0/1
duplex full
speed 100
switchport mode trunk
spanning-tree vlan 1 port-priority 1
!
interface FastEthernet0/2
duplex full
speed 100
switchport mode trunk
spanning-tree vlan 1 port-priority 2

interface FastEthernet0/24
duplex full
speed 100
switchport access vlan 20
spanning-tree portfast
+++++++++++++++++++++++++++++++++++++++++

rgs
a. rahman isnaini r.sutan

Make a Comment

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Liked it here?
Why not try sites on the blogroll...

%d bloggers like this: